Currently, common terms use a mix of naming conventions:
- Some are "flat", e.g. magnifierEnabled
- Some are "hierarchical", e.g. display.screenEnhancement.magnification
- Some are provisional (and hierarchical), e.g. display.screenEnhancement.-provisional-magnifierPosition
Common terms were meant to be flat, i.e. without dots in the local ID after the URI http://registry.gpii.org/common/.
(Sidenote: The transformer at https://github.com/GPII/universal/blob/master/testData/ontologies/ontologies.json converts between flat and hierarchical terms.)
This issue affects the transformers / solution registries and the matchmakers (e.g. training data for the statistical matchmaker) and therefore looks out of scope for the second pilot phase.