Uploaded image for project: 'GPII - Global Public Inclusive Infrastructure'
  1. GPII - Global Public Inclusive Infrastructure
  2. GPII-3400

Various issues observed with latest gpii-windows version

    XMLWordPrintable

    Details

      Description

      We have been testing the PSP/QSS with the newest version of `gpii-windows` (0.3.0-dev.20180926T111640Z.283aa31) and discovered some interesting issues:

      Issue1

      Configuration: "gpii.config.untrusted.development.dynamicDR.all.local"
      Steps to reproduce:

      1. Start the GPII app using `npm run dev`.
      2. Change the "High / Low Contrast" from the QSS to a value different from regular contrast.

      Expected result: The new value of the "High / Low Contrast" setting is applied and the user can perform subsequent tasks without any trouble.

      Actual result: The new value of the "High / Low Contrast" setting is applied but an error saying that "Morphic can't start app" appears and the user can no longer reset the QSS, nor can he key in as a different user.

      Logs: issue1.txt

      Note that this behavior does not happen when using the "gpii.config.untrusted.development.all.local.json5" configuration.

       

      Issue 2

      Configuration: "gpii.config.untrusted.development.all.local.json5"
      Steps to reproduce:

      1. Start the GPII app using `npm run dev`.
      2. Try to key in using the "Multiple pref sets. Magnifier & Volume Control" profile (i.e. `snapset_4d`).

      Expected result: The settings for `snapset_4d` are applied successfully and the "Magnifier" application is started.

      Actual result: The settings for `snapset_4d` are not applied, the "Magnifier" application is not started and 3 errors are displayed to the user: "A setting was not changed", "Morphic can't start app", "Oops. Something went wrong"

      Logs: issue2.txt

      Note that when using the "gpii.config.untrusted.development.dynamicDR.all.local" configuration, the "Magnifier" application is started, no errors are displayed to the user but the "Volume" setting is no longer shown in the PSP.

        Attachments

        1. issue1.txt
          73 kB
        2. issue2.txt
          247 kB

          Issue Links

            Activity

              People

              Assignee:
              cli@ocad.ca Cindy Qi Li
              Reporter:
              georgi.todorov Georgi Todorov
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: