Uploaded image for project: 'GPII - Global Public Inclusive Infrastructure'
  1. GPII - Global Public Inclusive Infrastructure
  2. GPII-4478

The defaults CANNOT be applied in QSS on start

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Quick Strip Set
    • Labels:
      None

      Description

      This is closely related to:
      https://issues.gpii.net/browse/GPII-4477

      In distributeQssSettings we are applying the new settings that comes from the payload. But in order this to work (and for us to see it applied to the QSS itself) we need to add seemingly random timeout.

      Sometimes work with 2 seconds, sometimes don't work even with 5 seconds delay.

      If the delay is enough you can open QSS and see that the default language is BG (for example) and the current language is BG. 

      If its not enough then the default values from settings.json (ie the hardcoded ones) are visible. Like the language is EN, and so on.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              karadaliev Danail Karadaliev
              Reporter:
              karadaliev Danail Karadaliev
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated: